Copfilter 2.1.92beta4 für IPCop 2.1.5

Dieses Forum ist für alle Copfilter v2 support Anfragen in Deutsch. (IPCop version 2)
karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by karesmakro » 04 May 2014 11:05

Copfilter 2.1.92beta4

Wir freuen uns die Copfilter 2.1.92beta4 für IPCop 2.1.5 veröffentlichen zu können!
Die Version enthält einige Fehlerbehebungen und ein paar kleine Updates

Changelog:
  • - replaced mailscanner.sh to work with p3scan blacklist and whitelist
    - fixed copfilter_functions to fix spamd problems on proxsmtpd
    - sqlite 3.8.4.3
    - php 5.4.28
    - some other small fixes
Installationsbeschreibung:

Die Installation der neuen Version erfolgt wie beim letzten Copfilter Update. Zuerst Copfilter deinstallieren, danach das IPCop 2.1.5 Update und den Reboot durchführen, anschließende Installation der neuen Copfilter 2.1.92beta4 Version. (Backup und Restore nicht vergessen!)

Download und vollständige Changelog findet ihr auf http://www.copfilter.org/pg64

Feedback erwünscht! :)

ron
Posts: 89
Joined: 11 Dec 2009 20:00
Contact:

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by ron » 04 May 2014 15:11

Hallo,

mh seit dem update hängt er mir bei jeden Seitenaufruf die IP und Hostname mit an, was natürlich zu einem "404 - File not found" etc führt. Wenn ich den Proxy deaktiviere funktioniert es wieder.

http://www.heise.de/192.168.2.10/pc.heimnetz-GET

Gruß
Ron

ron
Posts: 89
Joined: 11 Dec 2009 20:00
Contact:

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by ron » 04 May 2014 15:28

ok scheint ein Problem mit dem Update-Accelerator zu sein, wenn er abgestellt ist funzt es wieder. Werde mal die neue Version davon testen.

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by karesmakro » 04 May 2014 15:45

Hi Ron und danke für dir Rückmeldung!

Das hat etwas mit dem Intercept Modus im Proxy zu tun. Wenn der nicht richtig gesetzt ist, dann kommt es zu solchen Effekten!
Dieses Problem tritt nicht auf, wenn der Proxy nicht auf Transparent gesetzt ist.

Kare

ron
Posts: 89
Joined: 11 Dec 2009 20:00
Contact:

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by ron » 04 May 2014 15:57

Hallo Kare,

es lag am Update Accelerator, mit Version 2.2.2 läuft alles wieder.
http://blockouttraffic.de/ua_changelog.php

Damit ich mails bekomme war auch wieder ein /root/copfilter/setup_util -SF nötig. Die monit mails kommen allerdings auch ohne diese Anpassung.

Gruß
Ronny

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by karesmakro » 04 May 2014 18:41

Alles was über das Script sendEmail verschlüsselt rausgeht, benötigt die Anpassung.
Werde mich in der nächsten Version darum kümmern, dass es nicht mehr notwendig ist.

Greetz

ron
Posts: 89
Joined: 11 Dec 2009 20:00
Contact:

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by ron » 08 May 2014 07:16

Hallo Kare,

ich habe seit 2.1.5 das Problem dass der C-ICAP beim Neustart immer hängt. Musste gerade beim Clamav update ein restartsquid machen damit er wieder ans laufen kommt. Hast Du da eine Idee?

squid 31103 0.5 39.7 1494112 1439108 ? Rl May05 18:04 (squid-1) -s

May 8 07:07:50 router squid[31103]: WARNING! Your cache is running out of filedescriptors
May 8 07:08:06 router squid[31103]: WARNING! Your cache is running out of filedescriptors
May 8 07:08:22 router squid[31103]: WARNING! Your cache is running out of filedescriptors
May 8 07:08:38 router squid[31103]: WARNING! Your cache is running out of filedescriptors
May 8 07:08:54 router squid[31103]: WARNING! Your cache is running out of filedescriptors
May 8 07:09:10 router squid[31103]: WARNING! Your cache is running out of filedescriptors

Gruß
Ronny

Frank
Posts: 63
Joined: 09 Dec 2009 17:00
Location: Im Norden

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by Frank » 08 May 2014 08:08

habe in der Aktuellen Version auch arge Probleme mit dem Squid bzw dem Cache_log
Auch ein einspielen der Squid Binarys ohne C-Icap unterstützung mittels des setup_util klappte nicht da das Backup nicht gefunden wurde :?:

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by karesmakro » 08 May 2014 08:18

Läuft bei euch SquidGuard URLFilter?

Frank
Posts: 63
Joined: 09 Dec 2009 17:00
Location: Im Norden

Re: Copfilter 2.1.92beta4 für IPCop 2.1.5

Post by Frank » 08 May 2014 08:27

mit dem Url-Filter habe ich mich noch nicht befaßt dh. alles auf Standard...nur mit dem setup_util die Squid binarys mit c-Icap unterstützung Installiert und dann kamen die Fehlermeldungen bezüglich des Cache_log des squid's und normale http Seiten wurden nicht mehr gefunden....https Seiten gehen weiterhin und Anwendungen wie Skype oder Radio via Gadget läuft auch.

Post Reply