Page 1 of 1

copfilter webproxy issues

PostPosted: 03 Jan 2014 07:11
by appler
ipcop version: 2.0.6


i installed "copfilter" today. the install was successful

i then started the ipcop web proxy and allowed "transparent on Green". i could still browse internet as all internal hosts point to gateway of ipcop.


however after starting copfilter's c-icap & havp service, i could no longer browse internet from internal machines.

i stopped the c-icap & havp service for now.

question1: are the services c-icap & havp really necessary along with ipcop's squid transparent proxy?

question2: will clamav and apamassassin function as needed with just the ipcop's squid transparent proxy?

Re: copfilter webproxy issues

PostPosted: 03 Jan 2014 16:01
by FischerM
Hi and welcome to Copfilter-Forum!

appler wrote:i then started the ipcop web proxy and allowed "transparent on Green".

First, I would recommend to use web-proxy in non-transparent mode and configure your hosts to use squid-proxy accordingly: hosts must point to [IP_OF SQUID][PORT_OF_SQUID].

appler wrote:...after starting copfilter's c-icap & havp service, i could no longer browse internet from internal machines.

Which errors did you get? Anything hepful in the logs?
But for beginners, you shouldn't start C-ICAP and HAVP together! C-ICAP is meant as an alternative for HAVP. However, you could use the URLFilter section of C-CIAP together with HAVP, but must know exactly what to activate and what not.

I'd recommend to take a close look at the Copfilter-Wiki before you try to work with Copfilter, especially the section Basics: Features and first setup.

HTH
Matthias

P.S.: SPAM deleted.