Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Dieses Forum ist für alle Copfilter v2 support Anfragen in Deutsch. (IPCop version 2)
karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by karesmakro » 03 Aug 2013 20:04

Released Copfilter 2.0.91beta3

Copfilter 2.0.91beta4 ist eine Komponenten Update und Bugfix Version, integriert mit einem Flash-Installer (axs dot at). Die Priorität galt der Stabilität und der Packet Updates, nachdem die letzte Version jetzt schon über ein Jahr zurück liegt.

Großen Dank an Severus, FischerM, ShelbyGT500 und alle Foren-Mitglieder für die Ideen, Korrekturen und Erweiterungen!

Changelog:
  • - newest 3rd Sigs (Severus)
    - new C-ICAP / HAVP Templates (ShelbyGT500)
    - updated and modified language files (FischerM)
    - flash installer (company axs dot at)
    - modified interection between C-ICAP, HAVP and Privoxy
ein vollständiges Changelog findet ihr unter:

Download: http://www.copfilter.org/pg64
md5sum: 72f3ef7e5b2d71a2c8fbe430172c99f2

Update: Ich habe leider wieder mal vergessen, Severus für seinen unermüdlichen Einsatz in die 3rd Sigs endlich in den Credits mit aufzunehmen! @Severus, kannst du mir nochmal verzeihen? :oops:
Last edited by ShelbyGT500 on 16 Nov 2014 13:04, edited 1 time in total.
Reason: Sticky>Normal post because obsolete version

ron
Posts: 89
Joined: 11 Dec 2009 20:00
Contact:

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by ron » 03 Aug 2013 21:12

Update lief Problemlos, DANKE. Wie steht es eigentlich um den Firefilter, spiele gerade mit dem Gedanken auf IPFire umzusteigen?

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by karesmakro » 03 Aug 2013 21:34

Danke für deine Rückmeldung, ron! :)

Die IPFire Integration ist jetzt im Anschluß geplant und wir werden uns in den nächsten Wochen damit befassen, wie eine Umsetzung zu realisieren ist ;)

http://forum.ipfire.org/index.php?topic ... icseen#new

Frank
Posts: 63
Joined: 09 Dec 2009 17:00
Location: Im Norden

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by Frank » 05 Aug 2013 10:28

Moin zusammen,
Update lief auch bei mir ohne Probleme durch, allerdings werden nun folgende Werte bei mir auf den Konfigurationsseiten fest vorgegeben.

E-Mail / Absenderadresse: und / SMTP-AUTH Passwort:

AntiSpam / IMAP-Server (IP:Port): und / IMAP-Passwort:

und zwar werden dort Werte aus der Netzwerk / Einwahl Seite eingetragen welche sich auch nicht überschreiben lassen...auch sind diese Felder gelb hinterlegt

Lg Frank

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by karesmakro » 05 Aug 2013 20:56

Danke für die Rückmeldung!
Du meinst, es werden die Einstellungen aus den E-Mail Einstellungen unter System -> E-Mail-Einstellungen (aus IPCop) übernommen?
Ich kann das Problem leider nicht nachvollziehen, es werden eigentlich auch keine Werte aus der IPCop Konfiguration für die Mail Einstellungen ausgelesen!

Gibt es in der httpd_error.log Meldungen dazu?

Grüße, Kare

Update: richtig lesen hilft sich besser :) aber dennoch, es sollten keine Werte ausgelesen werden. Ich werde das überprüfen.

Frank
Posts: 63
Joined: 09 Dec 2009 17:00
Location: Im Norden

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by Frank » 05 Aug 2013 23:07

und ich werde das Paket morgen noch einmal installieren...ohne backup und restore

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by karesmakro » 05 Aug 2013 23:18

Bei einem Restore müssen auf allen Copfilter Konfigurationsseiten die Einstellungen nochmal ohne Neustart gespeichert werden!
Falls C-ICAP + Blacklist installiert war, muss auf der C-ICAP Konfig Seite die Blacklist aktiviert (ohne Speichern) und die Blacklist heruntergeladen werden.
Danach kann auf der Status-Seite der Button "Alle Dienste neu starten" gedrückt werden.

So sollte ein Backup ohne Probleme übernommen werden.

Juston
Posts: 3
Joined: 15 Aug 2013 08:41

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by Juston » 15 Aug 2013 09:05

Hallo,

ich habe nach dem Update das Problem das die Mails nicht mehr gefiltert und das ausgehende Mails beim Empfänger nicht mehr umgesetzt werden. Nur das reine Script mit Inhaltsdaten wird angezeigt:

/ 54 / - 2013-08-09 13:01
Received: from ([]) by
([0]) with mapi; Thu, 15
Aug 2013 08:50:10 +0200
From:
To:
Date: Thu, 15 Aug 2013 08:50:10 +0200
Subject: test
Thread-Topic: test
Thread-Index:
Message-ID:
Accept-Language: de-DE
Content-Language: de-DE
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
acceptlanguage: de-DE
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
X-Copfilter-Originating-IP: 192.168


Im Header empfangener Mails steht:

X-Filtered-With: Copfilter Version 2.0.91beta4 @ http://www.copfilter.org
X-Copfilter-Filtered-With: ProxSMTP 1.8


Aber Spam Assessin scheint nicht mehr zu filtern obwohl aktiviert. Im Log steht seitdem nur noch folgendes. Mails werden scheinbar nur noch mit der Whitelist abgeglichen?

Aug 14 08:07:28 clean message (-100.0/6.0) 0sec Copfilter_Whitelist
Aug 15 05:48:31 clean message (-100.0/6.0) 0sec Copfilter_Whitelist
Aug 15 05:48:31 clean message (-100.0/6.0) 0sec Copfilter_Whitelist


Ich habe mich eigentlich genau an die Update Anleitung gehalten.

mfg
Juston

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by karesmakro » 15 Aug 2013 17:31

Hallo Juston und willkommen im Copfilter Forum!

Wurde an der mailscanner.sh oder der copfilter_functions etwas verändert?
Könntest du testweise die Copfilter Kommentare für den Header und E-Mail Body ausschalten und danach das Blacklisting in ProxSMTP?

Was mich irritiert sind die "0sec" in der Logdatei! Das dürfte so dort gar nicht stehen.
ist das der Originalauszug?

Grüße, karesmakro

Juston
Posts: 3
Joined: 15 Aug 2013 08:41

Re: Copfilter 2.0.91beta4 für IPCop 2.0.3 - 2.0.6

Post by Juston » 15 Aug 2013 19:02

Hallo karesmakro,

ich habe nur den Eintrag /etc/rc.d/init.d/copfilter_proxsmtpd config_fwrules in der rc.firewall.local weil in der Vorgängerversion mein ProxSMTP auch ab und an dicht gemacht hat.

Die Copfilter Kommentare habe ich nun mal ausgeschaltet, Mails kommen jetzt wieder korrekt an. Was genau soll ich in ProxSMTP aus bzw. einschalten?

Die "0sec" steht so Original im Log.

Gruss

Post Reply