Page 1 of 1

Problem Updateing ClamAV to 0.98.3

Posted: 07 Jun 2014 12:23
by moshari_3
Hi Guys,

I noticed that my ClamAV was a little behind & had actually stopped running.
So I'm running IPC V 2.0.6 with CopFilter V 2.0.91beta3

In Terminal I got the following.
copy program files ...
Clamav debug mode disabled
starting clamd /var/log/copfilter/default/opt/clamav/default/sbin/clamd: /usr/lib/libxml2.so.2: no version information available (required by /var/log/copfilter/default/opt/clamav/0.98.3/lib/libclamav.so.6)
/var/log/copfilter/default/opt/clamav/default/sbin/clamd: /usr/lib/libxml2.so.2: no version information available (required by /var/log/copfilter/default/opt/clamav/0.98.3/lib/libclamav.so.6)
/var/log/copfilter/default/opt/clamav/default/sbin/clamd: /usr/lib/libxml2.so.2: no version information available (required by /var/log/copfilter/default/opt/clamav/0.98.3/lib/libclamav.so.6)
/var/log/copfilter/default/opt/clamav/default/sbin/clamd: /usr/lib/libxml2.so.2: no version information available (required by /var/log/copfilter/default/opt/clamav/0.98.3/lib/libclamav.so.6)
LibClamAV Warning: **************************************************
LibClamAV Warning: *** The virus database is older than 7 days! ***
LibClamAV Warning: *** Please update it as soon as possible. ***
LibClamAV Warning: **************************************************
LibClamAV Error: cli_tgzload: Invalid checksum for file daily.mdb
LibClamAV Error: Can't load /var/log/copfilter/default/opt/clamav/virdb/daily.cld: Malformed database
ERROR: Malformed database
FAILED

Cleaning up directories


Starting C-ICAP 0.3.3 Reinstall...

Stopping C-ICAP if enabled
extract program files


C-ICAP 0.3.3 successful installed


Reinstalling HAVP-0.92a!

Stopping havp if enabled
copying program files

HAVP 0.92a successful installed

Restarting Havp if enabled ...
Not activated ... no restart required ...
Restarting C-ICAP if Virus Scan is enabled ...

Update finished

And in the log file I have:
Sat Jun 7 20:16:20 2014 -> +++ Started at Sat Jun 7 20:16:20 2014
Sat Jun 7 20:16:20 2014 -> clamd daemon 0.98.3 (OS: linux-gnu, ARCH: i386, CPU: i686)
Sat Jun 7 20:16:20 2014 -> Running as user spam (UID 1001, GID 1002)
Sat Jun 7 20:16:20 2014 -> Log file size limited to 15728640 bytes.
Sat Jun 7 20:16:20 2014 -> Reading databases from /var/log/copfilter/default/opt/clamav/virdb
Sat Jun 7 20:16:20 2014 -> Not loading PUA signatures.
Sat Jun 7 20:16:20 2014 -> Bytecode: Security mode set to "TrustSigned".
Sat Jun 7 20:16:27 2014 -> ERROR: Malformed database

Any thought / suggestions greatly appreciated.

Re: Problem Updateing ClamAV to 0.98.3

Posted: 07 Jun 2014 14:46
by ShelbyGT500
Hi moshari_3,

Please:
1.delete all files and folders in /var/log/copfilter/default/opt/tmp (edit: /tmp for 2.0.91beta4)
2.replace the value (time to wait until next update) in /var/log/copfilter/default/etc/clamd_counter with 0
3.reboot IPCOP (necessary after installing 0.98.3)
4. wait 5 min for update.

Regards.

ShelbyGT500

Re: Problem Updateing ClamAV to 0.98.3

Posted: 07 Jun 2014 16:02
by ShelbyGT500
Hi,

The culprit for you error:
karesmakro wrote:ClamAV 0.98.3 for copfilter 2.1.92beta-x avaliable
Not compatible with 2.0.91beta3

regards.

ShelbyGT500

Re: Problem Updateing ClamAV to 0.98.3

Posted: 08 Jun 2014 03:07
by moshari_3
Hi Shelby,

There are no files in /var/log/copfilter/default/opt/tmp

So I take it I need to do the following.
1. Remove Copfilter.
2. Update IPCop to Ver 2.1.5
3. Install Copfilter
4. Install ClamAV 0.98.3 for copfilter 2.1.92beta-x avaliable.

Is that about it?

Thanks.

Re: Problem Updateing ClamAV to 0.98.3

Posted: 08 Jun 2014 10:41
by ShelbyGT500
Hi,
moshari_3 wrote:There are no files in /var/log/copfilter/default/opt/tmp.
Yes, it is only for 2.1.92betaX (/tmp for 2.0.91beta3-4).
moshari_3 wrote:So I take it I need to do the following.
1. Remove Copfilter.
2. Update IPCop to Ver 2.1.5
3. Install Copfilter
4. Install ClamAV 0.98.3 for copfilter 2.1.92beta-x avaliable.
Is that about it?
Yes, with:
5.reboot IPCOP (necessary for 0.98.3).Don't forget to use the Fix for mail GUI - copfilter 2.1.92beta4

Konwn issue just after installing clamav-0.98.3: CPU 100% and incorrect database upload.If you have one of them:
1.delete all files and folders in /var/log/copfilter/default/opt/tmp
2.replace the value (time to wait until next update) in /var/log/copfilter/default/etc/clamd_counter with 0
3.reboot IPCOP (necessary after installing 0.98.3)
4. wait 5 min for update.

regards.

ShelbyGT500