Copfilter 2.1.92beta6 for IPCop 2.1.7 released

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
lhoedl
Posts: 12
Joined: 24 Nov 2014 12:15

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by lhoedl » 25 Nov 2014 09:51

karesmakro wrote:
I can confirm the described issue! I have there a quick fix, which will solve the spamassassin problems.
Can you please describe how to use this fix - or just unzip into the default installation?

hzsolt
Posts: 2
Joined: 21 Nov 2014 15:09

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by hzsolt » 25 Nov 2014 16:06

Hello ShelbyGT500,

I have tried your advice but it did not work.
I wrote a comma at the end of the last line and I wrote a new line at the end of the en.pl file:

'copfilter havp_advanced_config' => 'HAVP - Advenced Config',
'connected' => 'connected'

);

Than I run update_lang.sh.
Unfortunately nothing happend. IPCop start page did not changed. I cannot see the IP address and hostname.

Because I use hungarian langauage I have repeated this procedure in /var/log/copfilter/default/langs/hu.pl file. Result was the same.

Any advice?

Thanks in advance.

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by ShelbyGT500 » 25 Nov 2014 22:58

Hi,
lhoedl wrote:[Can you please describe how to use this fix - or just unzip into the default installation?
You need:
1. Copy the archive in/tmp
2. uncompress
3. install

Code: Select all

tar xzvf copfilter-2.1.92beta6_fix.tgz 
cd copfilter-2.1.92beta6_fix
./install
It is the same for all fix or addon for Copfilter.
hzsolt wrote:copfilter havp_advanced_config' => 'HAVP - Advanced Config',
'connected' => 'connected'
);
Unfortunately nothing happend.
It's not an issue with hungarian language. You need to have a comma at the end of each line, and not a comma if there is nothing.
Because you missed a comma , the en.pl file hangs, and can not fix the issue.

Please modify en.pl lang file. Correct end of the file should be:

Code: Select all

'copfilter havp_advanced_config' => 'HAVP - Advenced Config',
'connected' => 'connected',

);
Regards.

ShelbyGT500

lhoedl
Posts: 12
Joined: 24 Nov 2014 12:15

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by lhoedl » 26 Nov 2014 12:14

Hi,

my Problem is still not solved :(

I have installed:
copfilter-2.1.92beta6_fix.tgz
Fix-spamassassin-2.1.92beta6.tar.tgz
and
modded the en.pl file

Spam and Antivirus still dont work :(

When i try to install the admin-mod: copfilter-admin_0.2.3beta1.tar.gz
i get the comment: This mod is only for Copfilter 2.1.92beta3 or higher ...
but i am on beta6 ???

All Systems seem to run and are monitored ...
but when i send a test mail/spam nothing is changed -
i get them wihtout any changes
spamdigest.log can not be displayed or its empty

Please help me

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by ShelbyGT500 » 27 Nov 2014 00:20

Hi,
lhoedl wrote:Spam and Antivirus still dont work
Is P3scan enabled? if not, you need to enable it and choose to tag or quarantine . It should work.
Moreover, you can use this patch. Download: http://shelby.eurowireless.de/Fix/Fix-s ... a6.tar.tgz ( need to be installed after Kare fix).
lhoedl wrote:When i try to install the admin-mod: copfilter-admin_0.2.3beta1.tar.gz ;but i am on beta6 ???
You need to use admin-mod version 0.2.4 for 2.1.92beta6. See: viewtopic.php?f=9&t=978#p4876

Regards.

ShelbyGT500

lhoedl
Posts: 12
Joined: 24 Nov 2014 12:15

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by lhoedl » 27 Nov 2014 11:52

ShelbyGT500 wrote:Is P3scan enabled?
yes
ShelbyGT500 wrote:use this patch.
i have
ShelbyGT500 wrote:You need to use admin-mod version 0.2.4 for 2.1.92beta6.
thank you, i will try

lhoedl
Posts: 12
Joined: 24 Nov 2014 12:15

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by lhoedl » 27 Nov 2014 18:07

Ich habe inzwischen den Admin-mod 2.4 installiert - ging problemlos -
jedoch funktionieren Anti-Virus und Anti-Spam noch immer nicht.

Anti-Virus scanned zwar die Mails, löscht sie aber dann nicht ...
Anti-Spam - sieht man das wo, ob gescanned wird?? - auf jeden Fall bleibt die Quarantäne leer ...

In the meantime i installed the admin mod without Problems -
all lights are green and it Looks like it would work,
but anti-Virus and anti-spam are NOT WORKING ...

Anti-Vius scans the mails, but doesn't delete them ...
Anti-Spam - i dont know if mails are scanned - never get into the quarantine ...

Wäre echt dankbar für jede Hilfe ...
Was kann ich noch probieren??

Any help appreciated -
what can i try next?

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by ShelbyGT500 » 28 Nov 2014 00:13

Hi,

please type:

Code: Select all

cat /var/log/copfilter/default/etc/global_settings | egrep 'P3SCAN|POP3|SPAM|CLAM'
and post here the result.

Regards.

ShelbyGT500

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by ShelbyGT500 » 29 Nov 2014 00:57

Hi lhoedl,

I found the solution for your issue with IP adress and Domain on IPCOP Start GUI.

You need to modify the /var/ipcop/addons/lang/texts.pl.YOUR_LANGUAGE file (for example /var/ipcop/addons/lang/texts.pl.hu for hungarian), and replace

Code: Select all

%tr=(%tr,
);
with

Code: Select all

%tr=(%tr,
'connected' => 'Connected',

);
regards

ShelbyGT500

lhoedl
Posts: 12
Joined: 24 Nov 2014 12:15

Re: Copfilter 2.1.92beta6 for IPCop 2.1.7 released

Post by lhoedl » 30 Nov 2014 18:32

ShelbyGT500 wrote:I found the solution for your issue with IP adress and Domain on IPCOP Start GUI.
yes it worked! thank you!
ShelbyGT500 wrote:please type:
# cat /var/log/copfilter/default/etc/global_settings | egrep 'P3SCAN|POP3|SPAM|CLAM'

Code: Select all

CLAMD_BYTECODE_ENABLE=on
CLAMD_ENABLE=on
CLAMD_PHISHING_SIGS=on
CLAMD_SAFEBROWSE_ENABLE=on
CLAMD_SETDAY=08
CLAMD_SETHOUR=15
CLAMD_SETMINUTES=12
CLAMD_SETMONTH=05
CLAMD_SETYEAR=2004
CLAMD_UPDATE_METHOD=periodically
CLAMD_UPDATE_PERIOD=hourly
CLAMD_UPDATE_VALUE=4
CLAMD_VALID=yes
CLAMD_VIRUS_EZIPS=off
CLAMSCAN=$BASEDIR/opt/clamav/default/bin/clamdscan
DISABLE_SPAM_SCANNING_FROM_OUTGOING_MAIL=on
HTTP_CLAMAV_LIBRARY=off
HTTP_VIRUS_SCAN_CLAMAV=on
IMAP_NO_SPAM_FOLDER=testnospam
IMAP_SPAM_FOLDER=testspam
P3SCAN_ENABLE=off
P3SCAN_ENABLE_DEBUG=off
POP3_ATTACHMENT_SCAN=off
POP3_DOMAIN=
POP3_MAIL_ADD_BODY=on
POP3_MAIL_ADD_HEADER=off
POP3_MAIL_REWRITE_SUBJECT=off
POP3_SANITIZE_SCAN=off
POP3_SCAN_BLUE=off
POP3_SCAN_GREEN=on
POP3_SCAN_ORANGE=off
POP3_SCAN_RED=off
POP3_SPAM_QUARANTINE=on
POP3_SPAM_QUARANTINE_NOTIF=on
POP3_SPAM_SCAN=on
POP3_SPAM_SCAN_QUARANTINE_SCORE_LEVEL=6
POP3_SPAM_WHITELIST=off
POP3_VIRUS_ADMINNOTIF=off
POP3_VIRUS_QUARANTINE=off
POP3_VIRUS_QUARANTINE_REMOVAL_DAYS=14
POP3_VIRUS_SCAN=on
SMTP_SPAM_QUARANTINE=on
SMTP_SPAM_QUARANTINE_NOTIFY_USER=off
SMTP_SPAM_SCAN=off
SMTP_SPAM_SCAN_BOUNCE=off
SMTP_SPAM_SCAN_BOUNCE_SCORE_LEVEL=20
SMTP_SPAM_SCAN_DISCARD=off
SMTP_SPAM_SCAN_DISCARD_SCORE_LEVEL=20
SMTP_SPAM_SCAN_QUARANTINE_SCORE_LEVEL=15
SMTP_SPAM_WHITELIST=on
SPAMASSASSIN=$BASEDIR/opt/mail-spamassassin/default/bin/spamc
SPAMASSASSIN_DIR=$BASEDIR/opt/mail-spamassassin/etc/mail/spamassassin
SPAMASSASSIN_LINT=$BASEDIR/opt/mail-spamassassin/default/bin/spamassassin
SPAMD=$BASEDIR/opt/mail-spamassassin/etc/init.d/spamd
SPAMD_ENABLE=on
SPAM_DAILY_ADMIN=on
SPAM_DAILY_DIGEST=on
SPAM_SCAN_RBL=off
SPAM_SCAN_SCORE_LEVEL=6
SPAM_SCAN_SPEEDUP=on
SPAM_SCORE_BAYES_00=-2.600
SPAM_SCORE_BAYES_05=-0.400
SPAM_SCORE_BAYES_20=-2.000
SPAM_SCORE_BAYES_40=-1.000
SPAM_SCORE_BAYES_50=0.000
SPAM_SCORE_BAYES_60=1.000
SPAM_SCORE_BAYES_80=2.000
SPAM_SCORE_BAYES_95=3.000
SPAM_SCORE_BAYES_99=3.500
THRDP_SPAMATTACH_ENABLE=off
THRDP_SPAMIMG_ENABLE=off
THRDP_SPAM_ENABLE=on
THRDP_WSPAM_ENABLE=on
root@ipcop:~ #  cat /var/log/copfilter/default/etc/global_settings | egrep 'P3SCA                                                                                                       N|POP3|SPAM|CLAM'
CLAMD_BYTECODE_ENABLE=on
CLAMD_ENABLE=on
CLAMD_PHISHING_SIGS=on
CLAMD_SAFEBROWSE_ENABLE=on
CLAMD_SETDAY=08
CLAMD_SETHOUR=15
CLAMD_SETMINUTES=12
CLAMD_SETMONTH=05
CLAMD_SETYEAR=2004
CLAMD_UPDATE_METHOD=periodically
CLAMD_UPDATE_PERIOD=hourly
CLAMD_UPDATE_VALUE=4
CLAMD_VALID=yes
CLAMD_VIRUS_EZIPS=off
CLAMSCAN=$BASEDIR/opt/clamav/default/bin/clamdscan
DISABLE_SPAM_SCANNING_FROM_OUTGOING_MAIL=on
HTTP_CLAMAV_LIBRARY=off
HTTP_VIRUS_SCAN_CLAMAV=on
IMAP_NO_SPAM_FOLDER=testnospam
IMAP_SPAM_FOLDER=testspam
POP3_ATTACHMENT_SCAN=off
POP3_DOMAIN=
POP3_MAIL_ADD_BODY=on
POP3_MAIL_ADD_HEADER=off
POP3_MAIL_REWRITE_SUBJECT=off
POP3_SANITIZE_SCAN=off
POP3_SCAN_BLUE=off
POP3_SCAN_GREEN=on
POP3_SCAN_ORANGE=off
POP3_SCAN_RED=off
POP3_SPAM_QUARANTINE=on
POP3_SPAM_QUARANTINE_NOTIF=on
POP3_SPAM_SCAN=on
POP3_SPAM_SCAN_QUARANTINE_SCORE_LEVEL=6
POP3_SPAM_WHITELIST=off
POP3_VIRUS_ADMINNOTIF=off
POP3_VIRUS_QUARANTINE=off
POP3_VIRUS_QUARANTINE_REMOVAL_DAYS=14
POP3_VIRUS_SCAN=on
SMTP_SPAM_QUARANTINE=on
SMTP_SPAM_QUARANTINE_NOTIFY_USER=off
SMTP_SPAM_SCAN=off
SMTP_SPAM_SCAN_BOUNCE=off
SMTP_SPAM_SCAN_BOUNCE_SCORE_LEVEL=20
SMTP_SPAM_SCAN_DISCARD=off
SMTP_SPAM_SCAN_DISCARD_SCORE_LEVEL=20
SMTP_SPAM_SCAN_QUARANTINE_SCORE_LEVEL=15
SMTP_SPAM_WHITELIST=on
SPAMASSASSIN=$BASEDIR/opt/mail-spamassassin/default/bin/spamc
SPAMASSASSIN_DIR=$BASEDIR/opt/mail-spamassassin/etc/mail/spamassassin
SPAMASSASSIN_LINT=$BASEDIR/opt/mail-spamassassin/default/bin/spamassassin
SPAMD=$BASEDIR/opt/mail-spamassassin/etc/init.d/spamd
SPAMD_ENABLE=on
SPAM_DAILY_ADMIN=on
SPAM_DAILY_DIGEST=on
SPAM_SCAN_RBL=off
SPAM_SCAN_SCORE_LEVEL=6
SPAM_SCAN_SPEEDUP=on
SPAM_SCORE_BAYES_00=-2.600
SPAM_SCORE_BAYES_05=-0.400
SPAM_SCORE_BAYES_20=-2.000
SPAM_SCORE_BAYES_40=-1.000
SPAM_SCORE_BAYES_50=0.000
SPAM_SCORE_BAYES_60=1.000
SPAM_SCORE_BAYES_80=2.000
SPAM_SCORE_BAYES_95=3.000
SPAM_SCORE_BAYES_99=3.500
THRDP_SPAMATTACH_ENABLE=off
THRDP_SPAMIMG_ENABLE=off
THRDP_SPAM_ENABLE=on
THRDP_WSPAM_ENABLE=on
Is there something you can tell me from that Output?

Post Reply