CLAMD fails to load - SOLVED

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
Post Reply
moshari_3
Posts: 152
Joined: 07 Apr 2010 03:43
Location: Australia

CLAMD fails to load - SOLVED

Post by moshari_3 »

Hi guys,
Thanks so much for the latest update.

Having an odd problem since I upgraded though.
CLAMD fails to load using either HAVP or C-ICAP.
I get the same error in the log file.

Using HAVP:
"Thu Apr 2 12:18:24 2015 -> +++ Started at Thu Apr 2 12:18:24 2015
Thu Apr 2 12:18:24 2015 -> clamd daemon 0.98.6 (OS: linux-gnu, ARCH: i386, CPU: i686)
Thu Apr 2 12:18:24 2015 -> Running as user spam (UID 1001, GID 1002)
Thu Apr 2 12:18:24 2015 -> Log file size limited to 15728640 bytes.
Thu Apr 2 12:18:24 2015 -> Reading databases from /var/log/copfilter/default/opt/clamav/virdb
Thu Apr 2 12:18:24 2015 -> Not loading PUA signatures.
Thu Apr 2 12:18:24 2015 -> Bytecode: Security mode set to "TrustSigned".
Thu Apr 2 12:18:45 2015 -> Loaded 5244392 signatures.
Thu Apr 2 12:18:49 2015 -> LOCAL: Unix socket file /var/log/copfilter/default/opt/clamav/var/run/clamd.socket
Thu Apr 2 12:18:49 2015 -> LOCAL: Setting connection queue length to 30
Thu Apr 2 12:18:49 2015 -> ERROR: daemonize() failed: Cannot allocate memory
Thu Apr 2 12:18:49 2015 -> Socket file removed."

And using C-ICAP:
"Thu Apr 2 13:17:05 2015 -> +++ Started at Thu Apr 2 13:17:05 2015
Thu Apr 2 13:17:05 2015 -> clamd daemon 0.98.6 (OS: linux-gnu, ARCH: i386, CPU: i686)
Thu Apr 2 13:17:05 2015 -> Running as user spam (UID 1001, GID 1002)
Thu Apr 2 13:17:05 2015 -> Log file size limited to 15728640 bytes.
Thu Apr 2 13:17:05 2015 -> Reading databases from /var/log/copfilter/default/opt/clamav/virdb
Thu Apr 2 13:17:05 2015 -> Not loading PUA signatures.
Thu Apr 2 13:17:05 2015 -> Bytecode: Security mode set to "TrustSigned".
Thu Apr 2 13:17:25 2015 -> Loaded 5245761 signatures.
Thu Apr 2 13:17:28 2015 -> LOCAL: Unix socket file /var/log/copfilter/default/opt/clamav/var/run/clamd.socket
Thu Apr 2 13:17:28 2015 -> LOCAL: Setting connection queue length to 30
Thu Apr 2 13:17:28 2015 -> ERROR: daemonize() failed: Cannot allocate memory
Thu Apr 2 13:17:28 2015 -> Socket file removed."

I have 2GB ram and 2.6Ghz Processor.
I removed the old Copfilter, ran IPCOP updates then re-installed latest Copfilter.
Plenty of free space on both disk partitions.

I did a clean install instead of upgrading on another machine which is working fine.
Any thoughts or more info I can supply.

Thanks
Last edited by moshari_3 on 02 Apr 2015 05:40, edited 1 time in total.

moshari_3
Posts: 152
Joined: 07 Apr 2010 03:43
Location: Australia

Re: CLAMD fails to load

Post by moshari_3 »

OOPS my mistake.
I forgot to apply the changes to enlarge the swapfile after running IPCop updates.

Working fine now.

Thanks again.

Post Reply