Copfilter 2.1.92beta4 weirdness

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
Post Reply
Tacsko_2
Posts: 1
Joined: 27 Jul 2015 12:30

Copfilter 2.1.92beta4 weirdness

Post by Tacsko_2 » 27 Jul 2015 12:50

Hello Copfilter Gurus!

I have a weird problem with the mentioned version of copfilter.
Frequently we got a confirmation mail from one of Our partner, who is on Our whitelist.
But we haven't got the other messages from the same partner.

When the message arrived to the copfilter, i can found the message in the /var/log/copfilter/default/opt/proxsmtp/tmp folder, but then it's disappears from this folder, and the message won't arrive to the recipient, and it is not listed in any log file anymore. It seems the message doesn't leave the firewall.

What happens with this message? How can I trace or debug this message

The header of the message in the temp folder is:
X-Copfilter:Sender is in whitelist, skipped SpamAssassin
Received: by xx.xx.xx (Postfix, from userid 1008)
id A7BFF3807B; Mon, 27 Jul 2015 12:12:46 +0200 (CEST)
Date: Mon, 27 Jul 2015 12:12:46 +0200
From: xx.@xx.xx
To: xx@xx.xx
Subject: =?iso-8859-2?B?Vulneuk=?=
=?iso-8859-2?Q?s?= - Cg.01-10-047059/26
Message-ID: <20150727101246.GA27482@XXXX>
Reply-To: xx@xx.xx
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-2
Content-Disposition: inline
Content-Transfer-Encoding: 8bit
User-Agent: Mutt/1.5.17 (2007-11-01)

Any help would be appreciated.

Thanks,
Tacsko
Last edited by ShelbyGT500 on 28 Jul 2015 21:20, edited 1 time in total.
Reason: Remove some informations for privacy reasons

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Copfilter 2.1.92beta4 weirdness

Post by ShelbyGT500 » 28 Jul 2015 21:38

Hi,

And welcome on copfilter forum! :D

It seems you're using Proxsmtp to filter incoming mail ?

if yes:
What about the Proxsmtp log?
if there is nothing , please try from console

Code: Select all

/var/log/copfilter/default/opt/proxsmtp/etc/init.d/copfilter_roxsmtpd debug >> /tmp/proxsmtpdebug 2>&1
Then try another download of your mails and then watch the debug log when you've the issue.

After debugging restart with

Code: Select all

/var/log/copfilter/default/opt/proxsmtp/etc/init.d/copfilter_proxsmtpd restart
Post the debug informations.

If you're using P3scan:
check P3scan log
if there is nothing , please try from console

Code: Select all

/var/log/copfilter/default/opt/p3scan/etc/init.d/copfilter_p3scan debug >> /tmp/p3scandebug 2>&1
Then try another download of your mails and then watch the debug log when you've the issue.
After debugging restart with

Code: Select all

/var/log/copfilter/default/opt/p3scan/etc/init.d/copfilter_p3scan restart
Post the debug informations.

Note there are improvment and bugfix since 2.1.92beta4.It's highly recommanded to uninstall previous version and upgrade to 2.1.93beta1.

Regards.

ShelbyGT500

Post Reply