3rd_party_sigs for ClamAV

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 20 Jan 2013 03:50

New version released: viewtopic.php?p=4582#p4582
Severus

Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 02 Mar 2013 18:55

New versions released!

Current version for

IPCop 1.4.x with copfilter 0.84 up to 0.85.2: 0.56.3

IPCop 1.4.x with copfilter 0.85.3 or higher and IPCop 2.x.x with copfilter 2.0.91 and higher: 0.60.3

changes:
Improved http GUI for copatibility with ShelbyGT500 privoxy mod
Improved GUI for antivirus and http
Some minor fixes and changes
Imrpoved the cronfiles for better error catching
Improved http GUI for copatibility with ShelbyGT500 privoxy mod
Fixed copfilter_havp file for proper use on havp with TMPFS

viewtopic.php?p=486#p486

ljr0
Posts: 122
Joined: 21 Jan 2010 22:03

Re: 3rd_party_sigs for ClamAV

Post by ljr0 » 19 Mar 2013 23:19

I'm using 2.0.91beta3. Everytime I try to install the 0.60.3 update, the web page has a message at the top: Invalid input and I cannot restart the service, nor can I make any changes to the databases being used.

It instructions say that I should install this as an update, but I don't see anywhere how to do that, since 0.60.0 was in it previously and the install said to uninstall the old one first. I don't see anyway to do an update.

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: 3rd_party_sigs for ClamAV

Post by ShelbyGT500 » 19 Mar 2013 23:56

Hi ljr0,

Please can you check and report for httpd_error.log (see in test and log GUI) ?

Regards.

ljr0
Posts: 122
Joined: 21 Jan 2010 22:03

Re: 3rd_party_sigs for ClamAV

Post by ljr0 » 20 Mar 2013 00:16

[error] [client 10.11.100.2] /var/log/copfilter/default/opt/tools/bin/check-c_icap-update-time.sh: line 21: ( * 60 ) + : syntax error: operand expected (error token is "* 60 ) + "), referer: https://10.11.100.15:8443/cgi-bin/copfi ... ivirus.cgi

But I'm not using I-CAP and so haven't recompiled. Is that the issue?

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: 3rd_party_sigs for ClamAV

Post by ShelbyGT500 » 20 Mar 2013 20:57

Hi ljr0,
ljr0 wrote:[error] [client 10.11.100.2] /var/log/copfilter/default/opt/tools/bin/check-c_icap-update-time.sh: line 21: ( * 60 ) + : syntax error: operand expected (error token is "* 60 ) + "), referer: https://10.11.100.15:8443/cgi-bin/copfi ... ivirus.cgi
I don't understand why you have a message about /var/log/copfilter/default/opt/tools/bin/check-c_icap-update-time.sh in httpd_error.log ? Nothing else in this log ?

if your /var/log/copfilter/default/opt/tools/bin/check-c_icap-update-time.sh file is corrupted, you can download and install the last version of it (fixes somes bugs) , see : viewtopic.php?f=9&t=705&start=20#p3622

For the issue for Antivirus GUI, Did you check MD5 for your 0.60.3 file downloaded ? Have a try to re download

Regards.

Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 22 Mar 2013 01:06

Sorry,
Icouldn't reproduce the problem.
The only known bug is in copfilter_mail.cgi for V1.
In there there must be deleted line 234

Code: Select all

$copfiltersettings{'UPDATE_MAIL_NOTIF'} !~ /^(on|off)$/ || 
because this setting is checked twice, once with false values.

Can you verify in any way what value is declared false?

Tegards
Severus

Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 29 Mar 2013 09:12

New version released!

viewtopic.php?p=4740#p4740

Severus

Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 27 Apr 2013 03:12

New versions released!
Current version for

IPCop 1.4.x with copfilter 0.84 up to 0.85.2: 0.56.5

IPCop 1.4.x with copfilter 0.85.3 or higher and IPCop 2.x.x with copfilter 2.0.91 and higher: 0.60.5


Because of changed temporary directories it's strictly recommended to uninstall previous versions first!


viewtopic.php?p=4801#p4801

Severus
Site Admin
Posts: 457
Joined: 10 Dec 2009 07:01
Location: Nürnberg - Germany

Re: 3rd_party_sigs for ClamAV

Post by Severus » 12 May 2013 11:24

New versions released!
Image
Current version for

IPCop 1.4.x with copfilter 0.84 up to 0.85.2: 0.56.6

IPCop 1.4.x with copfilter 0.85.3 or higher and IPCop 2.x.x with copfilter 2.0.91 and higher: 0.60.6



viewtopic.php?p=4801#p4801

Post Reply