Copfilter 2.0.91beta2 for IPCop 2.0.3 / 2.0.4

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
Post Reply
karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Copfilter 2.0.91beta2 for IPCop 2.0.3 / 2.0.4

Post by karesmakro » 14 Feb 2012 22:59

Released Copfilter 2.0.91beta2

Copfilter 2.0.91beta2 was mainly prepared, to run with IPCop 2.0.3.
There was added some new options to C-ICAP and updated some perl modules.

If you plan to update from previous copfilter release and update your IPCop to 2.0.3, you should at first
create a backup of your Copfilter settings. After them uninstall Copfilter, ugprade IPCop to 2.0.3 and then
install Copfilter 2.0.91beta2. Reboot your IPCop, afterwards restore your Copfilter settings, check or change
your settings and restart all services on Copfilter status page.

For C-ICAP users, you should know that you have to install the C-ICAP integrated squid binary again,
because of a squid update. You have to enable C-ICAP explicit, because of some new options are avaliable.
  • - C-ICAP SVN 836
    - sqlite 3.7.10
    - PHP 5.3.10
    - updated french langs (thanks to ShelbyGT500)
    - fixed well known fpscand problem in copfilter_antivirus.cgi (thanks to FischerM)
    - added database info option for mail body/header in antivirus gui (thanks to Severus)
    - extended/reworked C-ICAP Selftest
For download and detailed Changlog, view http://www.copfilter.org/pg64

Regards

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta2 for IPCop 2.0.3 / 2.0.4

Post by karesmakro » 16 Feb 2012 20:51

Just an update: Copfilter 2.0.91beta2 is also released for the IPCop 2.0.4 version!

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Copfilter 2.0.91beta2 for IPCop 2.0.3 / 2.0.4

Post by karesmakro » 17 Feb 2012 22:25

I have missed a bug in the setup_util script, which causes that the c-icap squid binary uninstall does not work

Please download this patch: http://www.copfilter.org/v2-downloads/f ... eta2.patch
and run following command:

Code: Select all

patch -p0 < ./setup_util_2.0.91beta2.patch
the commands now

Code: Select all

-U, --uninstall-icap    to restore default squid binary
-W, --with-icap         install squid with icap support
-R, --regrazor          registriere Razor

Post Reply