Problem with C-ICAP and Privoxy on 2.091beta2 (SOLVED)

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Problem with C-ICAP and Privoxy on 2.091beta2 (SOLVED)

Post by ShelbyGT500 » 17 Feb 2012 23:26

Hi ,

I don't know if it's because the bug in the setup_util script, which causes that the c-icap squid binary uninstall does not work, but i noticed 2 problems:
(I uninstalled previous 2.091beta2-rc1)

Problem 1:
If C-icap is enabled, i can't access the internet .

I activate the debug mod for c-icap. Here is the report:
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16854 died ...
Child 16854 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16855 died ...
Child 16855 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16856 died ...
Child 16856 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16857 died ...
Child 16857 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16858 died ...
Child 16858 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16859 died ...
Child 16859 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16860 died ...
Child 16860 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16861 died ...
Child 16861 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Free Servers: 10, children: 1. Going to start a child .....
Child 16862 died ...
Child 16862 did not exit normally.signaled with signal:11
Register in shared mem, qsize=20 stat_block_size=488 childshared data:880
Going to execute start child commands
Check command:srv_clamav:dbreload, type: 3
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:0 allocations: 1
Allocating from objects pool object 4
Environment created OK.
Data dir set to /var/log/copfilter/default/opt/c_icap/etc/blacklists/adult/.
^CSIGINT signal received for main server.
Possibly a term signal received. Monitor process going to term all children
Going to term children....
SIGINT signal received for main server.
DB setup OK.
open db domains.db: No such file or directory
open db urls.db: No such file or directory
Storing to objects pool object 4
Storing to objects pool object 4
Check command:open_sg_db, type: 8
Execute command:open_sg_db
pool hits:1 allocations: 1
Allocating from objects pool object 4
Child 16863 died with status 11
Service info shutdown!
Destroy lookup table /var/log/copfilter/default/opt/c_icap/etc/selftest.txt
Storing to objects pool object 0
Destroy lookup table multi.surbl.org
Storing to objects pool object 0
Storing to objects pool object 0
Destroy lookup table dnsbl.proxybl.org
Storing to objects pool object 0
Storing to objects pool object 0
Destroy lookup table http.dnsbl.sorbs.net
Storing to objects pool object 0
Storing to objects pool object 0
Destroy lookup table socks.dnsbl.sorbs.net
Storing to objects pool object 0
Storing to objects pool object 0
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
sg_release_db: sg_db is not open?
Exiting....


I can't open the icap server log: it is very very very big....

Problem 2:
I've not the number of version in the status Gui (3.0.19)
if privoxy is enabled in c-icap gui, the process is not running in the status gui.


EDIT 1
Here is the Monit log:
[CET Feb 17 22:00:41] info : monit HTTP server stopped
[CET Feb 17 22:00:41] info : monit daemon with pid [19991] killed
[CET Feb 17 22:00:41] info : 'system_ipcop.localdomain' Monit stopped
[CET Feb 17 22:00:43] info : Starting monit daemon with http interface at [*:446]
[CET Feb 17 22:00:43] info : Starting monit HTTP server at [*:446]
[CET Feb 17 22:00:43] info : monit HTTP server started
[CET Feb 17 22:00:43] info : 'system_ipcop.localdomain' Monit started
[CET Feb 17 22:00:43] error : 'privoxy' process is not running
[CET Feb 17 22:00:44] info : 'privoxy' trying to restart
[CET Feb 17 22:00:44] info : 'privoxy' start: /var/log/copfilter/default/opt/privoxy/etc/init.d/copfilter_privoxy
[CET Feb 17 22:01:14] error : 'privoxy' failed to start
[CET Feb 17 22:03:14] error : 'privoxy' process is not running
[CET Feb 17 22:03:14] info : 'privoxy' trying to restart
[CET Feb 17 22:03:14] info : 'privoxy' start: /var/log/copfilter/default/opt/privoxy/etc/init.d/copfilter_privoxy
[CET Feb 17 22:03:44] error : 'privoxy' failed to start
[CET Feb 17 22:05:44] error : 'privoxy' process is not running
[CET Feb 17 22:05:44] info : 'privoxy' trying to restart
[CET Feb 17 22:05:44] info : 'privoxy' start: /var/log/copfilter/default/opt/privoxy/etc/init.d/copfilter_privoxy
[CET Feb 17 22:06:14] error : 'privoxy' failed to start
[CET Feb 17 22:08:14] error : 'privoxy' process is not running
[CET Feb 17 22:08:14] info : 'privoxy' trying to restart
[CET Feb 17 22:08:14] info : 'privoxy' start: /var/log/copfilter/default/opt/privoxy/etc/init.d/copfilter_privoxy
[CET Feb 17 22:08:44] error : 'privoxy' failed to start
[CET Feb 17 22:10:44] error : 'privoxy' process is not running
[CET Feb 17 22:10:44] info : 'privoxy' trying to restart
[CET Feb 17 22:10:44] info : 'privoxy' start: /var/log/copfilter/default/opt/privoxy/etc/init.d/copfilter_privoxy
[CET Feb 17 22:11:14] error : 'privoxy' failed to start
[CET Feb 17 22:13:14] error : 'privoxy' service restarted 5 times within 5 cycles(s) - unmonitor

[CET Feb 17 22:21:37] info : Awakened by the SIGHUP signal
[CET Feb 17 22:21:37] info : Reinitializing monit - Control file '/var/log/copfilter/default/opt/monit/etc/monitrc'
[CET Feb 17 22:21:37] info : Shutting down monit HTTP server
[CET Feb 17 22:21:38] info : monit HTTP server stopped
[CET Feb 17 22:21:38] info : Starting monit HTTP server at [*:446]
[CET Feb 17 22:21:38] info : monit HTTP server started
[CET Feb 17 22:21:38] info : 'system_ipcop.localdomain' Monit reloaded
[CET Feb 17 22:21:39] info : Awakened by the SIGHUP signal
[CET Feb 17 22:21:39] info : Reinitializing monit - Control file '/var/log/copfilter/default/opt/monit/etc/monitrc'
[CET Feb 17 22:21:39] info : Shutting down monit HTTP server
[CET Feb 17 22:21:40] info : monit HTTP server stopped
[CET Feb 17 22:21:40] info : Starting monit HTTP server at [*:446]
[CET Feb 17 22:21:40] info : monit HTTP server started
[CET Feb 17 22:21:40] info : 'system_ipcop.localdomain' Monit reloaded


Regards.
Last edited by ShelbyGT500 on 18 Feb 2012 01:07, edited 1 time in total.

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by karesmakro » 17 Feb 2012 23:32

A simple answer solves your problem: reboot your IPCop and all went o.k. ;)
I remember, you already had a problem with that
It's important, to reboot ICop after Copfilter installation!

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by ShelbyGT500 » 17 Feb 2012 23:36

Hi Kare,

I don't think.
I' rebooted IPCOP several times .
But I'll try anyway!

Regards

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by karesmakro » 17 Feb 2012 23:42

Which IPCop version are you using?
It looks like the libraries can not be loaded!
You also shouldn't have *.db files in the c-icap blacklist directories on selected categories

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by ShelbyGT500 » 17 Feb 2012 23:46

Hi,
karesmakro wrote:I remember, you already had a problem with that
Yes, you're right, and I had to reinstall copfilter to solve the problem .

But the problem with Privoxy is new.

EDIT
I rebooted IPCOP, but it didn't resolve this issue.

Regards

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by ShelbyGT500 » 18 Feb 2012 00:10

Hi,

I will reinstall Copfilter.

I noticed during uninstalling :
Continuer ? [y/N]y
Ok, désinstallation en cours..
arrêt de tous les services..
mo:2345:respawn:/var/log/copfilter/default/opt/monit/default/bin/monit -I -c /var/log/copfilter/default/opt/monit/etc/monitrc
monit ne fonctionne pas
Done
privoxy ne fonctionne pas
POP3 Filtrage du trafic activé sur GREEN: lan-1

p3scan tué Done

proxsmtpd tué Done
suppession des règles du firewall
frox ne fonctionne pas
Pas de règles actives, frox ftp Filtrage inactif
havp ne fonctionne pas
imspector ne fonctionne pas
Waiting .
spamd tué Done
Waiting ..
clamd tué Done
fpscand ne fonctionne pas
Waiting .
c-icap tué Done

=======================================================================================


Suppression de /var/log/copfilter ok
Suppression des scripts de CopFilter de /usr/local/bin ok
Suppression de /root/.razor et /root/.spamassassin ok
Suppression des scripts de démarrage de /etc/rc.d/rc.event.local ok
Suppression des scripts de démarrage de /etc/rc.d/rc.firewall.local ok
Suppression des utilisateurs et groupe CopFilter ok
Suppression des scripts d'initialisation de CopFilter de /etc/rc.d/init. ok
Suppression des entrées CopFilter du crontab ok
remove copfilter librariesldconfig: /usr/lib/libsfbpf.so.0 is not a symbolic link

ldconfig: /usr/lib/libdaq.so.0 is not a symbolic link

ldconfig: /usr/lib/libnet.so.1 is not a symbolic link

ok
Suppression de unzip de /usr/local/bin ok
Suppression de wget de /usr/local/bin ok
Suppression de la documentation de CopFilter de /home/httpd/html/copfilt okoc
Suppression de l'interface graphique de CopFilter ok
Suppression clamav statistics webpage ok
Suppression de l'interface graphique pour les whiteliste et blackliste ok
Restauration /etc/rsyslog.conf et kill -HUP syslog ok
Restauration de /etc/httpd/conf/httpd.conf et redémarrage de httpd ok
Suppression des fichiers de langue ok
Suppression des entrées CopFilter de /etc/squid/squid.conf ok
Suppression des entrées CopFilter de /home/httpd/cgi-bin/proxy.cgi ok
Suppression des liens du dossier CopFilter de /root ok

Désinstallation terminée avec succès !


Regards.

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by karesmakro » 18 Feb 2012 00:49

Do not know what on your IPCop installation happens, but something is wrong on your machine and I recommend you, to install your IPCop new!
ShelbyGT500 wrote:But the problem with Privoxy is new.
well observed
Copfilter-Changelog wrote:- privoxy: removed statically linked pcre (because of safety concerns) - use external one
not using the old pcre libs, which comes with privoxy and since 2008 recommended to remove ...

I ask you again, on which IPCop version you are trying to install the Copfilter 2.0.91beta2?

Could you also check, if your root partition is not running out of order

Believe me, I've tested the functionallity of the services, before it was released

ShelbyGT500
Posts: 846
Joined: 13 May 2010 22:37
Location: FRANCE

Re: Problem with C-ICAP and Privoxy on 2.091beta2

Post by ShelbyGT500 » 18 Feb 2012 01:07

Hi Kare,
karesmakro wrote:I ask you again, on which IPCop version you are trying to install the Copfilter 2.0.91beta2?
It's IPCOP 2.0.4
karesmakro wrote:Do not know what on your IPCop installation happens, but something is wrong on your machine and I recommend you, to install your IPCop new!
Y're right. i reinstalled Copfilter. It works fine.

I noticed theses informations during uninstalling :
remove copfilter librariesldconfig: /usr/lib/libsfbpf.so.0 is not a symbolic link
ldconfig: /usr/lib/libdaq.so.0 is not a symbolic link
ldconfig: /usr/lib/libnet.so.1 is not a symbolic link


Regards.

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Problem with C-ICAP and Privoxy on 2.091beta2 (SOLVED)

Post by karesmakro » 18 Feb 2012 01:20

last one today
Please never leave the c-icap debug mode unattended for a longer time!
If you have problems with libraries, the c-icap log is very fast in size!

I assume, your varlog partition was running out of space on last installation
remove copfilter librariesldconfig: /usr/lib/libsfbpf.so.0 is not a symbolic link
ldconfig: /usr/lib/libdaq.so.0 is not a symbolic link
ldconfig: /usr/lib/libnet.so.1 is not a symbolic link
and that should not occur on a working IPCop installation and this library is never touched by Copfilter!

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: Problem with C-ICAP and Privoxy on 2.091beta2 (SOLVED)

Post by karesmakro » 18 Feb 2012 09:34

Hi,
I have seen, unfortunately, only today
ShelbyGT500 wrote:(I uninstalled previous 2.091beta2-rc1)
So I can imagine what happens.
This test release was only running on IPCop installations, where the libraries didn't changed.
If you can remember one of a mail from me, I wrote you that this libraries changed and a rebuild of copfilter is necessary for running on latest release ... :D

Why did you marked this thread as solved?

regards, karesmakro

Post Reply