ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

This forum is for all copfilter version 2 support related questions in English. (IPCop version 2)
Post Reply
karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by karesmakro » 15 Jun 2012 19:23

Hello there!

I know it's a little time has passed, I had really much to do and there was no chance, to maintain the forum or Copfilter. There was only a few day's and was curious, to see the new C-ICAP 0.2.0 (at this time, only a prerelease) changes and performance. There are some new features (which aren't yet implemented in Copfilter).

The reason, why I speak about C-ICAP (and why it is integrated in the ClamAV 0.97.5 update-release) is, that it was necessary to recompile C-ICAP anyway after installing the new ClamAV 0.97.5 version, to work with the new library. And I thought, why not updating to the newer C-ICAP release, which is running well since ~4 weeks on my machines (and FischerM's machine)

Because it is a bigger update, I want to have some testers and their feedback, before publishing the release! I would be happy, if someone have a testing machine :)

you can find the download link in the Devel forum: http://copfilter.org/forum/viewtopic.ph ... 73&start=0

Regards

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by karesmakro » 17 Jun 2012 19:11

O.k. it's time to update the ClamAV Version again ;)

Changelog ClamAV: http://git.clamav.net/gitweb?p=clamav-d ... mav-0.97.5

Changelog C-ICAP
- Shelby was working on the URL-Filter templates, which is now showing the corresponding categorie of the blocked site (Thank you very much)
- extension for the C-ICAP startup process, which is now detecting, if C-ICAP crashes (no need to wait 5 minutes again :) )

Download für Copfilter 2.0.91beta3: http://www.it-connect-unix.de/copfilter ... ackage.tgz
md5sum: 5f6ff52326943403e040b50418be2d38

Download für Copfilter 2.0.90: http://www.it-connect-unix.de/copfilter ... ackage.tgz
md5sum: a221835da6a73a1d32b420455a310e54

Installation for Copfilter 2.0.91beta3:

Code: Select all

tar xzvf clamav_0.97.5_copfilter-2.0.91beta3-package.tgz
cd clamav_0.97.5_copfilter-2.0.91beta3-package
./install
There are some steps you have to do, after installing the update:
  • 1. install the ClamAV with C-ICAP update
    2. deactivate C-ICAP in the Copfilter GUI
    3. reboot your IPCop
    4. Download and convert your Blacklist Database for URL-Filter again
    5. activate C-ICAP and start it
For the Copfilter 2.0.90 Update, you have to adapt the package names!

Great Thanks to FischerM and ShelbyGT500 for testing!

regards

cjseven
Posts: 2
Joined: 29 Aug 2012 14:28

Re: ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by cjseven » 29 Aug 2012 14:41

Hello,

I'm running Copfilter 2.0.91beta3 and I recently installed the ClamAV_0.97.5_copfilter-2.0.91beta3 package. Before the update, I was running HAVP, but I've since disabled it due to scanning issues.

Here's what my clamd log was showing after the update:

Mon Aug 27 07:52:08 2012 -> SelfCheck: Database status OK.
Mon Aug 27 08:48:23 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-xRoWOm: CL_EFORMAT: Bad format or broken data ERROR
Mon Aug 27 08:48:52 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-9AYSs6: CL_EFORMAT: Bad format or broken data ERROR
Mon Aug 27 08:51:58 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-NUYrum: CL_EFORMAT: Bad format or broken data ERROR
Mon Aug 27 08:52:06 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-WrElRp: CL_EFORMAT: Bad format or broken data ERROR
Mon Aug 27 08:52:08 2012 -> SelfCheck: Database status OK.
Mon Aug 27 08:52:15 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-siWTGi: CL_EFORMAT: Bad format or broken data ERROR
Mon Aug 27 08:52:17 2012 -> /var/log/copfilter/default/opt/havp/tmp/havp-FNKZPD: CL_EFORMAT: Bad format or broken data ERROR

I believe the source of the problem may be the ClamAV binaries, as I'm seeing other reports on the web regarding the CL_EFORMAT error.
See link here: http://ubuntu.5.n6.nabble.com/Bug-10154 ... 87817.html

Perhaps, though, I should be running C-ICAP and not HAVP?
Any thoughts?

Thanks,
cjseven

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by karesmakro » 29 Aug 2012 19:38

Hello cjseven and welcome to the Copfilter Forum!

Are there any error log entries in the clamd.log? I didn't heard about this error yet and there was also no bug report about this issue in the clamav mailinglist.
I'm using C-iCAP in my environment for a longer time and never had log entry like this. Perhaps you should try to use C-ICAP, but I'm going to prepare a recompiled havp binary, perhaps this helps.

regards

karesmakro
Site Admin
Posts: 1280
Joined: 09 Dec 2009 21:17

Re: ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by karesmakro » 29 Aug 2012 20:07

here you can find the new binary for havp:
http://www.it-connect-unix.de/copfilter ... 0.97.5.tgz
md5sum: c39ce19431c864a1e327bf416ae17c6f

Code: Select all

tar xzf copfilter-v2-havp_0.92a-cl0.97.5.tgz
cd copfilter-v2-havp_0.92a-cl0.97.5
./install

cjseven
Posts: 2
Joined: 29 Aug 2012 14:28

Re: ClamAV 0.97.5 and C-ICAP 0.2.0pre for Copfilter v2

Post by cjseven » 30 Aug 2012 15:10

Karesmakro,

Thanks very much for your assistance. I installed the new havp binary, but the problem persisted, so I chose to use C-ICAP instead.

There were no errors in clamd log, except those I posted previously, and there are no new ones since turning off havp and enabling C-ICAP.

Thanks again,
cjseven

Post Reply